Samba 2.0.0 on Solaris 7

Jeff Ross jeff.ross at
Thu Apr 8 16:04:51 GMT 1999

I installed the pre-compiled samba 2.0.0 for Solaris 2.6 on a Ultra-10
workstation running Solaris 7.

On my NT 4.0 workstation, I can see my samba server, but can't access my
share. I went through the diagnostics (DIAGNOSIS.txt). Test 1 through Test 7
passed. Test 8 (net view <server> in a DOS window) returns:

Sytem Error 5 has occurred.
Access is denied.

The diagnostics says that if something similar to this occurs, insert an
entry in hosts.allow. I don't think Solaris uses hosts.allow, but I tried it
anyway. It didn't help.

My smb.conf file has only what the diagnostics suggested, and nothing else:

 comment = temporary files
 path = /tmp
 read only = yes

I also tried adding a global section with a hosts allow line for my PC. That
didn't help.

I am running smbd at debug level 3. As the documentation suggested, the log
messages are not terribly helpful, but here are the last few messages smbd
posted in response to my net view request.

 Requested protocol [NT LM 0.12]
[1999/04/08 09:31:06, 3] smbd/negprot.c:reply_negprot(409)
  Selected protocol NT LM 0.12
[1999/04/08 09:31:06, 3] smbd/process.c:timeout_processing(755)
  end of file from client
[1999/04/08 09:31:06, 2] smbd/server.c:exit_server(406)
  Closing connections
[1999/04/08 09:31:06, 3] smbd/server.c:exit_server(431)
  Server exit (normal exit)

I don't think there is a problem with my PC configuration, as I am able to
access another samba server (HPUX 10.20) with no problems. 

I'm new to Solaris and new to Samba. I know the answer is something simple
that I forgot to do, but I'm stumped, and I apologize in advance for
bothering thousands of people with this.

Can anyone out there help?


- Jeff 

More information about the samba mailing list