win95 ppp connection to samba- password again

anoah at anoah at
Fri Apr 2 06:20:15 GMT 1999

thanks to the samba crew- we have converted several netware and nt user
servers into one seam-less Unix network, except for one group, netware dialup

ok, win95 client, ppp to linux server. using newest pppd, with correct ms-wins
and ms-dns code. client can dial, gets wins server ips, etc. the client
functions fine with tcp-ip stuff. the ppp server is the wins server.

go to client and do a \"net view\" and it finds the server. try to do a \"net
view \\\\server\" and it says password is bad, contact sysadmin. I am the
sysadmin, but i am not making contact!

i have set the dialup connection under the 95 client to logon to network,
though i usually leave it off.

i tried doing domain logons on the box as well, since that is what the server
is doing on the lan, and i want it to do here. same deal, client says
\"password was incorrect or domain server unavail\" (which one, microsoft? those
are _SO_ different events)

i turn up log level in samba, but it does no good- lots of other stuff gets
more verbose, but the single error never does -
it says in the log.default (the systems name):

\"Address already in use\"

now, this does not seem to be like when you get that in syslog, cause i cant
find anything in syslog at all! just in this samba log for the machine.

the server is linux, RH 5.2 kernel 2.2.1 with software raid as the only patch.
samba is 2.0.0. it is a heavily used production server, but i can upgrade
kern. and samba over the break if you guys think that might help.

note: the server has 2 NIC\'s, one on public, whole class C network
( NM) and the other on private class C-size network,
same NM. win95 ppp picks wrong NM for the private, but right NM for the other.
i have tried putting the modem on both sides, same error. since win95 is using
wins, the netmask does not seem to matter.

problem #2- perhaps this belongs on samba-tech:

it briefly said something about another ip on this network not liking my name
registration or something. what was apparently happening was that i was logged
in to another box with the same username. even though the other client
computer has a different name, samba complained until i logged out of the
other box! now this complaint above is all that is left.

problem 3#- this is not samba, but perhaps it will help someone with more
experience than i. i cannot do a tcpdump on any interface. talks about socket
types. have i got some strange linux kernel stuff going on? if so i can revert
to 2.0.36, but i really like the caching in 2.2.x

many thanks for your hard work,
pfeiffer university and our few thousand users are in your debt.

allan noah
unix admin, pfeiffer u.

ps- please respond to me direct as well

More information about the samba mailing list