new user question

Joe Wronkowski jwronkowski at
Mon Sep 14 19:46:00 GMT 1998

thanks for the response from everyone.  I have recompiled the kernal and
the compiler worked fine.  I have switched ram also. To me it dosn't seem
to be hardware related because i have compiled many things with no problems
until now.  also compiling the kernal takes a lot and if it has not problem
with that why should it with that one file.  any way I guess i could try to
upgrade the gcc but I am confused at what file i need do you know the name
of it so I can download it.  I went to under sunstiet/GCC and
there was many files but none that i could recognize.  
thanks in advance.

Joe Wronkowski

At 08:25 AM 9/14/98 +1200, you wrote:
>> Compiling ufc.c
>> Compiling smbpass.c
>> cc: Internal compiler error: program cc1 got fatal signal 6
>> make: *** [smbpass.o] Error 1
>> quake2:/usr/src/samba-1.9.18p10/source# 
>Does the PC have a Cyrix/IBM 6x86 CPU? If so, this error can happen on
>big compiles (tried recompiling the kernel?) and there are a number of
>reasons why. The most common I've seen are either bad hardware (esp.
>memory), insufficient CPU cooling, or if you're using RedHat 5.0, the
>distributed [g]cc would do this too. In the latter case, either upgrade
>to a more recent gcc (I got one from sunsite.unc) or upgrade to RedHat
>There are some docs on the WWW that describe how hardware problems can
>cause this error, try Altavista for details. 
>Simon Greaves				voice: (+679) 212114
>Computer Centre				fax:   (+679) 304089
>The University of the South Pacific	email: greaves_s at
>Suva, Fiji

More information about the samba mailing list