Sometime cannot connect to samba server, Why ?

Panyarak Aaron Ngamsritragul panya at
Tue Oct 27 15:33:39 GMT 1998

I have posted this question 3-4 weeks ago, but still get no response.

In my environment, I have one Linux box running Samba 1.8.18p5, and 
there are about 20 Win95 clients which is in the same network.
The porblem I usually encountered is when I click on the samba server
icon in the NN icon, sometime I can get thru without any problem.
However, there are also many times that I got error message like
"cannot access resource" (Something like this, cannot remember precisely).

I also discovered that, once the samba server denied connection, I login
to the Linux box using Telnet client, become root and kill the smbd
process, I will be able to connect to the server w/o problem.
But since it is not resonable at all to give root access to everybody
so that they can kill the process and get connect to server....

What can be the cause the this problem ?

I have included my smb.conf in this mail for your reference too.

i would like to add that, I have also tried to disable some unnecessary
protocols, such as NetBEUI, unbind Windows Network from IPX/SPX protocol,
but still cannot solve the problem.

Panyarak Ngamsritragul
Department of Mechanical Engineering
Prince of Songkla University.

More information about the samba mailing list