Problems compiling samba-1.9.18p10 on Solaris 2.6

Tajthy Tamas tajthy at
Wed Nov 25 09:54:51 GMT 1998

Dear Yasmine,

> From: "Yasmine Arafa" <Y.Arafa at>
> I have problems compiling samba-1.9.18p10 on Solaris 2.6.
> I get the following error msgs when I make the Makefile, what am I
> missing?:

I had the same problem using Solaris 2.5.1. Try to compile with cc -Xa (ansi 
compatible mode with C-R extensions).

I modified this section:

# This is for SUNOS5.4 and later (also known as Solaris 2.4 and later)
# contributed by Andrew.Tridgell at
LIBSM = -lsocket -lnsl
AWK = nawk

It worked for me. Which cc U use? I used /usr/ucb/cc. With -Xa it worked. 
There were a lotta redefinied #defines, but worked.

When I compiled PERL I have got problems with /usr/ucb/cc. It was adviced to 
use /opt/SUNWspro/bin/cc (put /opt/SUNWspro/bin to the PATH before /usr/ucb). 
It was said /usr/ucb is buggy.

It worked for PERL and Apache. Try it! I will also, 'cos I have to recompile 

Good byte From:, the recompiled

This is the first day of the rest of Your life!

More information about the samba mailing list