NT passowrd change problem

Thomas E. Knowles tek at CS.Princeton.EDU
Mon Mar 30 22:17:50 GMT 1998

Still no dice.  Same exact problem as before.  What's odd is that I have access
to 2 PDC's on two different physical subnets -- if I try changing my password to
the 8 character one I want on the PDC on my own subnet, it works perfectly. 
It's only when I try changing my password on the PDC on the other subnet that I
get this bizarre behavior.

Thomas E. Knowles
tek at CS.Princeton.EDU

Jeremy Allison wrote:
> Thomas E. Knowles wrote:
> >
> > Hmmm...this is odd though.  The password I'm trying to change to on the PDC is 8
> > characters.  Even odder is the fact that if I try to change to that same
> > password MINUS THE LAST CHARACTER, it works.  Then, when I go to change the
> > password to what I had tried originally (all 8 chars), it works there too.  It's
> > like I have to go through two steps to change to the password I want, and in the
> > end I still end up with the same 8 character password I wanted originally.  One
> > other thing, I have no problems changing to a 6-character password.  There's
> > nothing odd about my 8-character password, I can change to it just fine from an
> > NT box.
> >
> > Any ideas??
> >
> Yes. Are you using a unix getpass() routine that only
> allows 8 characters ? Try re-compiling with
> -DREPLACE_GETPASS in the Makefile - see if that
> fixes the problem.
> Jeremy.
> --
> --------------------------------------------------------
> Buying an operating system without source is like buying
> a self-assembly Space Shuttle with no instructions.
> --------------------------------------------------------

More information about the samba mailing list