Errors with smbtar

Grant, Les LGRANT at
Tue Mar 24 13:40:00 GMT 1998

Simon Hyde wrote:-

>On Thu, 19 Mar 1998 20:14:16 +1100, you wrote:
>>Hi all
>>	I have been using samba for some time now with no
>>problems. Recently I decided to try and backup NT workstations
>>with smbtar/smbclient to DAT tape. I get the following:-
>>getting file \DOS\COUNTRY.SYS of size 26936 bytes as a tar file
>>COUNTRY.SYSError writing to tar file - I/O error
>>Didn't get entire file. size=26936, nread=3856
>>Padding with 23080 zeros
>>This happens every few files. Note the 'nread' value is the same on
>>occasion. I have no
>>such problem if I am writing to disk, it is as if it write does not
>>block properly when waiting for
>>the dat drive to write the data to tape.
>You're almost at the solution there, doesn't block properly? Perhaps
>should try changing the blocksize? I came accross this exact problem
>6 months ago, changing the blocksize seemed to fix all my problems (512
>fixed it for me if I recall correctly). Basically, there is a parameter
>smbtar which specifies the blocksize (-b if I recall correctly, take a
>at man smbtar for more info) and you need to use it.

Not for me it hasn't. I tried 512 1024 and 2048.
The block size value is being passed as a larger block
of data is written before I get the error each time I increase
the block size.

Is anyone succesfully using smbtar with DAT tapes on HPUX 10.20 ??

Thanks for the input

			les grant

More information about the samba mailing list