NT drive mapping hangs with samba/solaris

Dan Fiscus fiscus at al.umces.edu
Wed Mar 11 15:13:44 GMT 1998


I have a problem with NT stations, both 3.51 and 4.0 - mapping  
network drives on a Sun Sparc running Solaris and samba 1.9.17p4. 
Drive connects can take a very long time and sometimes won't map 
at all or time out.

I have worked through the diagnosis steps posted on the samba
web site. Everything works up until test 8, which says to do 
net view \\servername. If I put in just the short host name,
without the full domain name, I get system error 53 network path
not found. If I put in the full hostname, net view works but 
only shows the one share that defaults to the user's home 
directory, not two other shares that are set up in smb.conf.

One other set of symptoms is that when an NT 4.0 (SP3) station 
is trying to map a samba drive at login, it will hang with the 
hourglass for >30 sec. When the NT station is in this delay
limbo, if I run netstat -a on the Sparc it also hangs. No 
results from netstat -a until the NT drive is mapped.

I would upgrade samba, but we have 1.9.17p2 running on a 
pentium here and those drive connections work flawlesly. I'd
like to be able to match that performance on the Sun.

Thanks much for any tips on how to troubleshoot this,

Dan Fiscus


Dan Fiscus                      email: fiscus at al.umces.edu
Research Assistant              phone: (301) 689-3115 ext. 103
University of Maryland 
Center for Environmental Science 
Appalachian Laboratory
Gunter Hall
Frostburg State University
Frostburg, MD 21532

More information about the samba mailing list