Windows NT/95 Cannot Login to Solaris Samba 1.9.18p3 Server

Eskandar Ensafi esky at
Wed Mar 11 01:54:32 GMT 1998


First of all, I wanted to mention that I do not subscribe to this
mailing list, so please reply directly to <ensafi at>.

I am running Samba 1.9.18p3 under Solaris 2.6 on a Sun Ultra 30,
Axil 320 (similar to SPARCstation 20) and a lowly SPARCstation 1.

When attempting to login to the Samba server from the Windows NT
Explorer (e.g., to access a user's home directory), only the guest
account seems to work (i.e., when I set 'public = yes' for [homes]
in smb.conf).  If I set 'public = no', attempting to connect using
any valid UNIX username/password fails with the error "Account not
authorized to login from this station."  I have tried adding user
names via 'user = ...' to the [homes] section, and even when I try
to connect as one of the listed users, I get the same error.  I
have also tried to connect using \\server\share%username with and
without using the "Connect As:" field in the Windows NT "Map Drive"
dialog, but it makes no difference.

Finally, I emulated the desired behavior (i.e., login to the Samba
server using the UNIX username that matches the current Windows NT
username) by putting 'public = yes' and 'guest account = %U' in the
[homes] section of smb.conf, but this is not a good solution, and
it only happens to work at our site because each UNIX user has a
PC named after his/her UNIX account (e.g., the NetBIOS name for
the PC beloging to UNIX user jdoe is also jdoe).

I also find it strange that %U evaluates to the NetBIOS name of
the connecting PC, and not to the user account of the person
connecting from the PC (i.e., %U = %m unless another username is
specified).  Is this normal behavior for Samba 1.9.18p3, or is
something wrong?

I do not subscribe to this mailing list, so please please e-mail
your reply to <ensafi at>.

Thank you,

Eskandar Ensafi
Space Computer Corp.

More information about the samba mailing list