SUMMARY: Favorite print command for SAMBA on Sol 2.5.1

Dave dburwell at
Wed Jun 17 16:51:39 GMT 1998

  And the winner is...Jochen Eggemann 
  The problem appears to be HP JetAdmin. The "solution" seems to be to turn
off the "True End-of-Job" option for each printer.
  From the Jetadmin menu:
  1) Configuration (super-user only): 1
  5) Modify existing spooler queue(s) 5
                (Select your printer) hp5si-28
  4) Additional printer changes . . . 4
  2) True End-of-Job                      [OFF] 2

  Then save and exit for this printer. Set this option to [OFF] on all of
your JetAdmin printers. This option is set to [ON] by default.

  I changed this on Tuesday last week, and have had only one printer lock
up since then. Normally, I would expect at least 1 or 2 a day.

  ALSO: I have a UNIX Admin in the UK that was having the exact same
problem, and he WAS NOT running SAMBA. All of his clients were Sol 2.X and
the lockups were happening when his users were printing through the
printool instead of the command line. This solved his problem too.

  Other recommendations:
  Get rid of the Sol lp system completely. 
  Replace it with LPRng-3.5.1
  Even the documentation said this was a long process. I will save that one
for later.

  Others responded with their SAMBA print commands:

  print command = lp -c -d%p %s; rm %s

  Another suggestion was to add the fully qualified path to the commands:
  print command  = /usr/ucb/lpr -r -P%p %s
  printcap name  = /bin/lpstat
  lpq command    = /usr/ucb/lpq -P%p
  lprm command   = /usr/ucb/lprm -P%p %j

  Original Question:
>  I am having problems with the HP printers that are being handled by a
>Solaris 2.5.1 machine. The boring details are towards the end. 
>  The SAMBA print command I currently use is:
>print command = echo %u - %s to %p at %T >> /tmp/smb-print.log ; \
>                lpr -P %p %s ; \
>                rm %s
>  These are EXACTLY the way they are in the smb.conf file. The server will
>print 99.9% of the jobs, it is only a very small percentage that have
>  I have tried a "print command = lp -d %p %s"  but all of the jobs went
>into the bit bucket and nothing ever got printed and nothing showed up in
>the queues.
>  What is the "correct", or most popular, method?
>  If you want to help, please read the boring details included.
>  Also - Please respond directly via email, not this list.
>The REAL Problem:
>  A queue will choke on a print job submitted by a client. The job will sit
>at the top of the queue, and all other jobs will queue up behind it. Power
>cycling the printer has no effect. I have to do a lprm -P<printer>, on the
>server, to clear that job off the top of the queue, and then the remaining
>jobs will print without problems.
>  OR - A one page document, will print an infinite number of copies. (NOT
>PS code, but real copies of that one page document, like the user selected
>10000 as the number to print).
>  I have 10 of these printers, and the problem has occurred on all of them,
>but it never seems to effect more than one at a time. Once, on a really bad
>day, it hit three about an hour apart. Obviously, I see these problems more
>on the printers that are used the most.
>   The clients are using the HP 5si MX PS driver. The problem occurs with
>different users, different versions of the HP 5si MX PS driver on different
>Win95 clients using different versions of Win95, Win311, & NT, printing to
>different HP5siMX printers (we have 10 of them).
>  The common element is the Solaris Print server.
>Version Details:
>  The server machine has the Recommended Patches for 2.5.1 from April. It
>is Samba version 1.9.18p4 compiled on this machine - for this machine. The
>HP JetAdmin program is Rev. D.04.12. All printers are TCP/IP through the
>JetDirect cards, rev A.05.05.
>  As a added MacGuffen: I have a UNIX admin in the UK that is having a
>similar problem (queues lock up and infinite pages printed) - Except his
>clients are all Solaris 2.X and they use the printools GUI to send jobs to
>his printer server. His printer server is a Sol2.5.1 (like mine), with HP
>Jetdirect D.04.12 (like mine), and JetDirect Cards use the same fimeware
>version (like mine). 
>  Sun Support is looking into his problem, but they are stumped.
>dburwell at

More information about the samba mailing list