problem with shares and passwords

Carlos Eduardo Selonke de Souza carlos at
Mon Jun 1 17:29:15 GMT 1998


I am having problens with samba in FreeBSD 2.2.6
I read the DIAGNOSIS.txt and I am folowing the steps.
I will sumarize the problem

1. Making the bins
I edited the MakeFile and use this options for FreeBSD

LIBSM = -lcrypt

The bins compiled with no problems.


I am using just those lines in smb.conf

   comment = Temporary file space
   path = /tmp
   read only = yes

3.I made the registry update of my Nt4.0.
I tested it with other machine that runs samba. I use the " net use *
\\othermachine\share" and it worked ok. So I belive my NT4.0 is ok.

3.I run the testparm. It said that everything is OK

4.I run samba as daemon
/usr/local/samba/bin/smbd -D
/usr/local/samba/bin/nmbd -D

4.I run smbclient -L BIGSERVER
smclient gives this information for me
I changed my IP to, hope you dont mind.

%./smbclient -L ciclope
Added interface 
Server time is Mon Jun  1 14:36:43 1998
Timezone is UTC+0.0
Domain=[labsad] OS=[Unix] Server=[Samba 1.9.18p1]
SMBtconX failed. ERRSRV - ERRbadpw (Bad password - name/password pair in a
Tree Connect or Session Setup are invalid.)
Perhaps you are using the wrong sharename, username or password?
Some servers insist that these be in uppercase

That is my problem. SMBTconX failed.

I have alredy install samba in other FreeBSD and HP-UX both worked OK.

I hope anyone could help me.

Carlos Eduardo Selonke de Souza
Decision Support System Laboratory
mailto:carlos at
Magnus - Brasirc Network

More information about the samba mailing list