Samba and AIX3

Paulo Henrique M. Sant' Anna paulo at
Wed Jan 28 17:24:31 GMT 1998

 Hi all,

 I'm running samba 1.9.18p1 on four RS6000 with AIX 3.2.5. Until this version
I was unable to get "force user" to work. I still get the same message
"Can't set uid (AIX3)" but now it works! (I don't now why I thought it
was an AIX3 limitation). But I still got one complain. The directive
"browseable" seems to not work well on these machines. I have also two
Axil320 (Sparc 10 clones) with Solaris 2.5 and the same happens.
 The point is, when I try to write "browseable=no" the share turns into
unavaiable. So I have to make all my shares visible to all users, although
only valid users can cd into them. Any clues? One of my shares follows:

   comment = Comment
   path = /home/share1
   valid users = user1 user2 user3
#  browseable=no
   public = no
   writable = yes
   force user = share1
   printable = no
   create mask = 0770

 (without the comment # the share does not work)

 -- Paulo Henrique

More information about the samba mailing list