SAMBA digest 1557

Sean A. Snyder ssnyder at
Thu Jan 15 19:12:21 GMT 1998

> Date: Wed, 14 Jan 1998 09:09:57 -0500
> From: "Scott F. McCagg" <smccagg at>
> Subject: Samba spooling but not printing
> I have Samba running on Linux, file shares work fine. I use the most basic
> [printers] section (as shown in the smbd man page). The system spools files
> to the /tmp directory but they never print. I have added:
> [global]
>         printing = bsd
>         print command = lpr -s -r -P %p %s
> But nothing. I can login a telnet window as nobody and use that "print
> command" and it works fine. I'm stumped!
> Any help would be greatly appreciated.

I ran into a similar problem on Solaris back when I first installed
Samba near the beginning of the year.  In my incident, the problem
was solved by playing with the printer driver options on the
Windows machine. 

In my experience, the print job would spool to the server, show up
in the queues, and then get sent to the printer (HP5si and HP4mv
in my case).  The printer light would flash for a while, and then
the printer would just ignore the job and go on to the next print

Assuming that you are using some HP printer in postscript mode, try
playing around with the options in the Windows print driver.  I
believe the key options that got mine working were:
	1. Spool directly to port in Raw mode.
	2. Change postscript options from "Optimize for speed" to
		"Archive Format"

Best of luck.


Sean A. Snyder (ssnyder at         \ Strange but not a stranger
Systems Administrator                       \ I'm an ordinary guy... 
Campbell-Ewald Advertising/C-E Communications\_________________________

More information about the samba mailing list