Printer browsing- failing under Solaris 2.5.1

Dr Peter J. Goadsby peterg at
Fri Feb 13 09:26:16 GMT 1998

I am at a loss. I have two SUNs and 10 PCs (W95) on our network. One SUN
box runs Solaris 1.1.1, it has four serial printers (old printers never die
they just...) running from a serial extension card. Users validate when the
come to their PC so they can access the printers and the disks on the SUNs.
The second SUN runs 2.5.1 and I wanted to move the printer activity there
with time. I created two printers under Solaris running from the serial
ports. I can attach a serial printer and print from the 2.5.1 box and print
to the 2.5.1 printer from the 1.1.1 box and vice versa BUT none of the PCs
sees printers attached to the 2.5.1 box. I run Samba 1.9.18p2 on both
machines and use identical smb.conf files. On 1.1.1 the printers work fine
and on 2.5.1 I cannot access them via samba although I can using solaris
commands. The 2.5.1 machine is the domain master and the problem is
unaffected by turning off the 1.1.1 machine. I wondered if it was some
serial thing and recently installed a HP lasetjet on the network through an
ethernet card. I added it to the 2.5.1 machine and it all works fine but
again cannot be accessed through Samba (although it works fine from a W95
machine running JetAdmin etc). Has anyone had this problem with 2.5.1? It
should be said that I have tried perhaps 4 different Samba versions (last
one 1.9.17p1) and the problem is identical? Any suggestions?
	Peter Goadsby

More information about the samba mailing list