Can't join SAMBA-Domain

Anton Roeckseisen Anton_Roeckseisen at
Wed Feb 4 15:55:35 GMT 1998


I have set up samba 1.9.18p2 on a BSDI 3.0. As I tried to join the 
samba-server with a NT 4.0 Workstation (sp3,german) I got an error message 
indicating that my workstation has no account on the samba-server. Further 
tries doing the same thing only showed an error message that the Domain-Server 
for the domain I want to connect to cannot be found.

* I surely did NOT check this create account thing in the requester for 
changeing the domain!

* The workstation was in a one member workgroup just before I tried to join 
the samba-domain - it still is......

* Everything works fine on the workstation (browsing with explorer, connecting 
shares,...) except joining the other domain.

* joining the workgroup of the samba-server works with no problem!

* the workstation is configured to use the samba-server as wins-server

Any idea? If someone wants a detailed log file I can provide it, but I didn't 
want to post it on the list - so here is my smb.conf only:

Please have a look at the comment in [Profiles]!


   workgroup = ANTON
   domain sid = S-1-5-21-123-111-109-123
   browseable = yes
   encrypt passwords = yes
   security = user

   local master = yes
   os level = 60
   domain master = yes
   preferred master = yes
   domain logons = yes
   dns proxy = no 
   wins support = yes

   interfaces =

   logon script = %m.bat
   logon path = \\%L\Profiles\%U

      read only = no
      writable = yes
      browseable = yes
        path = /tmp
        browseable = yes
        writable = yes
        user = anton

   comment = Network Logon Service
   path = /usr/local/samba/lib/netlogon
   guest ok = yes
   writable = no
   share modes = no

    path = /usr/local/samba/profiles

    # if browseable = no then "net view \\server" exits
    # with a cannot allocate enough memory error.....!!!!????
    browseable = yes   

    guest ok = yes

More information about the samba mailing list