Password Problems on Solaris 2.5.1

Sean A. Snyder ssnyder at
Wed Feb 4 16:23:24 GMT 1998

> Date: Mon, 02 Feb 1998 21:02:36 -0500
> From: Timothy Gardner <tsg at>
> To: samba at
> Subject: Password Problems on Solaris 2.5.1
> Message-ID: <34D67ABC.4867B45E at>
> I installed samba for the first time on a Solaris 2.5.1 server.  The
> samba server is visible on our windows NT network and I can access our
> NT server using smbclient.  However, when I try to access the Samba
> server using smbclient, I get the following error message:

o Are you using NIS+ on this Solaris 2.5.1 server?  
o If using NIS+, does the /etc/.rootkey file exist?
o Are all of the users that you've tried to login as listed in NIS+?
o Have you tried creating a new user the the /etc/passwd file, and then
	using smbclient as that user?  Did it work?

I ran into a similar problem recently when evaluating TotalNet
Advanced Server on a newly-installed server.  For whatever reason,
when I initialized the machine as a NIS+ client, the nisclient script
did not write the server's private key into the /etc/.rootkey file.
As a result, the server was not able to correctly decrypt NIS+
user passwords.  If you're using NIS+ but are missing /etc/.rootkey,
do a keylogin -r as root and you should be all set.

Best of Luck!

Sean A. Snyder (ssnyder at         \ Strange but not a stranger
Systems Administrator                       \ I'm an ordinary guy... 
Campbell-Ewald Advertising/C-E Communications\_________________________

More information about the samba mailing list