oplock problem

Tomáš Kuba tkuba at seznam.cz
Mon Dec 14 23:50:22 GMT 1998


I need help (but who doesn's huh? :-) )
I meant to run one program - Money2000 (no, it is _not_ program from 
Microsoft) together with samba on linux, but i have problems with oplocks.

This program is installed locally on win9x/NT and shares its databases. We 
tried to place databases on novell, on NT server and on win95 acting as 
server and everything worked fine. But when we tried to run this program 
with databases on samba server under linux, the problems began. It was 
possible to start several instances of program on the same computer, but 
when we started program on another computer, the program returned something 
like "On another computer is running operation that needs exclusive access 
to databases. Stop this operation and try to run program once again". That 
error message should appear only if somebody is trying to re-index or 
backup databases.
The only way we were able to run the program on more than one machine was 
to set "fake oplocks = yes" which isn't very happy in network environment. 
So the problem seems to be with oplocks.

Is there some difference between samba's and win9x/NT's oplocks?

Does anybody know the solution of this problem?

We tried a lot of changes in configuration, but ... nothing.


Tomas Kuba

e-mail: tkuba at seznam.cz
Czech Republic

More information about the samba mailing list