user level authentication on Samba 2.0.0b4

Liam Hoekenga liamr at
Fri Dec 18 15:57:49 GMT 1998

First of, thanks to Robert Dahlem who pointed out that my "error 131" was
due to using a hosts allow statement, but not allowing 127. to connect

A new problem... 
I compiled samba on Solaris (Sparc) 2.6 with v4.2 of the sun CC compiler.
It compiles just fine, and I appear to have a working binary.  I run into
problems when trying to connect using smbclient.  It works if I specify my
username (using -U), but otherwise it won't connect.

Both NT and Sharity _seem_ to connect fine - I just tried them.. when I
could connect with smbclient, i asssumed the build was bad, so I hadn't
tried earlier.

Anyways here's a transcript of the problem...

felix% whoami
felix% smbclient -L felix
Added interface
session setup failed: ERRSRV - ERRbadpw (Bad password - name/password pair
in a Tree Connect or Session Setup are invalid.)
felix% smbclient -L felix -U liamr
Added interface
Domain=[GPCC] OS=[Unix] Server=[Samba 2.0.0beta4]

        Sharename      Type      Comment
        ---------      ----      -------
        tmp            Disk      Temporary file space
        IPC$           IPC       IPC Service (Samba Server v2.0.0beta4 on

        Server               Comment
        ---------            -------
        FELIX                Samba Server v2.0.0beta4 on felix
        LITTERBOX            Samba Server v1.9.18p10 on litterbox

        Workgroup            Master
        ---------            -------
        WORKGROUP            SUNSHINE

More information about the samba mailing list