[Trouble #6512] Samba shares not accessible

Kitty Ferguson ferguson at hao.ucar.edu
Mon Dec 7 17:51:48 GMT 1998


We're running Samba version 1.9.16p2 under Solaris 2.5.1 (w HW update 11/97). 
Our PCs run Windows95 with Network Neighborhood and a few have been upgraded to 
Windows98. I am currently looking at upgrading to Samba 1.9.18p10.

On Fri., 12/4 one of our users reported when she selecting Entire Network she 
received the error "Unable to browse the network. The specified computer didn't 
receive your request. Try again later." Her machine is running Windows95.

I tried stopping and restarting the smbd and nmbd processes, check smb.conf for 
any errors. I checked this on our test PC, running Windows98 and had the same 
results. In fact no shares show up when Network Neighborhood is selected. It 
displays only "Entire Network". All our PC have lost connection to the Samba 
shares. So this is happening with both Windows95 and Windows98 installations.

We also check with our networks group to be sure it was not a network problem. 
We can ping and access our clients<->server remotely.

The following have been checked, output looks good:
smbclient -L jabba

In addition to checking the web site and archives, I ran through the test suite 
in the Samba Diagnosis Procedure (Blair's book) and found a failure on the 
server as follows:

jabba# smbclient '\\FileServer\TMP'
Added interface ip= bcast= nmask=
Got a positive name query response from (
Server time is Sat Dec  5 18:30:28 1998
Timezone is UTC-7.0
Password: [running as root, entered root password]
Domain=[HAO] OS=[Unix] Server=[Samba 1.9.16p2]
first SMBtconX failed, trying again. ERRSRV - ERRinvnetname (Invalid network 
name in tree connect.)
SMBtconX failed. ERRSRV - ERRinvnetname (Invalid network name in tree connect.)
Perhaps you are using the wrong sharename, username or password?
Some servers insist that these be in uppercase

This was followed by tests from the client athena with failures as follows:
[athena is out test PC, curretnly running Windows98]

- to check nmbd I ran at DOS:
net view \\FileServer
with good results, shows the services from smb.conf

- Then ran Test 9 to check access to a share on the server:
net use X: \\FileServer\TMP
and should have been prompted for a password, but received aan error that I 
tried to access a directory that does not exist. Tried it with \tmp, same error.
	Plenty of room in /tmp.

- Test 10 suggest browsing the server for shares but the server is not even 
listed in Netwrok Neighborhood.

So we have tests of the server side with password failure and tests on the 
client side failing to find FileServer\TMP. 

Recent changes to the system include the following:

Until Nov 28 we were running Solaris 2.5.1 on our server; we then installed the 
11/97 hardware update and some of the Maintenance Update to allow support of 
Ultra 10's under 2.5.1.

we moved the location of one of the shared services, but it is still referenced 
with the same path (we have the auto_home path set for this).

edited the smb.conf file to add an NFS filesystem as a shared service

In trying to backup previous to this problem I modified the smb.conf file as 

Modified ig_proj path in smb.conf (w RCS), same error.
Removed riker/e entry in smb.conf, same error.
The file is currently where it was prior to any mods this past week, but that 
still does not address any possible conflicts with the Solaris 2.5.1 Hardware 

TIA for any help you can provide.


--Kitty Ferguson		System Administrator - CSMT
ferguson at hao.ucar.edu		NCAR - High Altitude Observatory	
tel: (303)497-1556		P.O. Box 3000
fax: (303)497-1589		Boulder, CO 80307-3000

More information about the samba mailing list