"handle is invalid" trying to connect

Ken Hardy ken at bridge.com
Tue Aug 18 17:14:20 GMT 1998

Couldn't find any references to this problem.  When a user tries to
connect to a Samba share from an NT machine, it takes its time and
eventually returns with the error "The handle is invalid".  This just
started happening, but it does not happen to others accessing the same
share.  This user is dialed in to the network with PPP (as she always
had been in the past when it worked).  I tried upgrading to Samba
version 1.9.18p8 but it didn't help.

And, coincidentally or not, large numbers of users suddenly cannot
resolve DNS names on Monday when they could on Friday.  I found they do
not have the local domain name in their NT networking setup, and they
can resolve a FQDN but not a plain hostname.  Don't think anyone went
around all offices changing network settings.  DHCP isn't being used,
I'm told.  Could a WINS change have affected this somehow?
The DNS server is unchanged and resolves fully qualified names okay.

Anyway, though the user gets a 'cannot find network address' when
trying to map the share by machine name, it finds the machine when
mapping by address, but the 'handle is invalid' error occurs.  What's

- KH

More information about the samba mailing list