SMB printing server problem... HELP ME !!!

Ernesto Silva a088 at
Fri Aug 7 02:09:46 GMT 1998

-------------- next part --------------
Hello everybody!!!

	First of all I must say that I'm not an English speaker, so this text may sound
a little extrange. I apollogize.....

Well, I'm having problems with the SMB printing system. I have spent a lot of time 
(nearly 15 hours and a houndred of configurations) in it but I could not use it as
a printing server.

System Configuration:

One LAN with two machines. (2 meter between them)

The Server:
Linux box running RedHat 5.0 (Pentium II at 266 MHz. with 64 Mb of RAM)
	Samba version 1.9.17p4 that came with RedHat distribution.
	Lan connection running OK. (telnet server ,ftp server ,etc.)

The Client:
WfW 3.11 box (486 DX2 at 66 MHz. with 8 Mb of RAM)
	Lan connection running OK. (telnet, ftp, etc)

The things that I can do now:

   a) Use the linux box as a file sharing system with SMB in a windows network.
	I can log in the linux box and access my files there from the WFW box whithout
	any problem.

   b) Use the WFW box as file sharing system with SMB an acces my files there from
	the linux box without any problem. (smbclient OK.)

   c) Use the linux printing system from the linux box. I can print text, postscript
	and everithing, so it is working perfectly.

The things that I CAN'T do now:

   a) Use the linux box as a printing server to acces it from the WFW box.(partialy)
	I can see the linux printer in the WFW box, but when I send somthing to the
	printer, it disapears (in the "ether" I supouse).

>From the WFW box I'm seeing 2 printers, but I only have one connected to the linux box
(both are the same I guess).

The Printers Administrator of WFW allows me to connect my LPTx port to the printer in 
the linux box without problems.

After that I start Word 6.0 or another application like the NotePad, load a file and try
to print it to the "network printer" in my linux box, the application tells me it's 
printing but      NOTHING HAPPENDS !!!!.

I have tried that many times also looking the Printer Administrator of WFW and nothing
is spooled. It's like the file never reaches the Printer Administrator. On the other 
hand, I can normally print in a printer connected to the parallel port of the WFW box.

I have read a lot of documentation, Readmes, FAQs, Diagnosis, etc. Eveybodoy sais it is
very easy to use the printing system under SMB, but I can't. So I'm looking for someone
not with the same problem but someone who has solved it.

Next, I'm sending my configuration files of the linux box and other specifications.

FILE: /etc/smb.conf  

; Make sure and restart the server after making changes to this file, ex:
; /etc/rc.d/init.d/smb stop
; /etc/rc.d/init.d/smb start

; Uncomment this if you want a guest account
; guest account = nobody
   log file = /var/log/samba-log.%m
   lock directory = /var/lock/samba
   share modes = yes
   workgroup = MYGROUP
   printing = bsd
   printcap name = /etc/printcap
   load printers = yes 
   server string = MYSERVER

   comment = Home Directories.
   browseable = no
   read only = no
   create mode = 750
   announce as = NT
   load printers = yes

   comment = Temporary file space.
   path = /tmp
   read only = no
   public = yes

   comment = Public Files.
   path = /c
   readonly = yes
   comment = HP-LJ 4000
   printer name = lp 
   printer driver = HP LaserJet 4/4M
   path = /var/spool/lpd/lp
   writable = no
   public = yes 
   printable = yes

FILE: /etc/printcap
# Please don't edit this file directly unless you know what you are doing!
# Be warned that the control-panel printtool requires a very strict format!
# Look at the printcap(5) man page for more info.
# This file can be edited with the printtool in the control-panel.

##PRINTTOOL3## LOCAL ljet4 300x300 a4 {} LaserJet4 Default 1


FILE: /etc/inetd.conf
# Version:      @(#)/etc/inetd.conf     3.10    05/27/93
# Authors:      Original taken from BSD UNIX 4.3/TAHOE.
#               Fred N. van Kempen, <waltje at>
# Modified for Debian Linux by Ian A. Murdock <imurdock at>
# Modified for RHS Linux by Marc Ewing <marc at>
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
# Echo, discard, daytime, and chargen are used primarily for testing.
# To re-read this file after changes, just do a 'killall -HUP inetd'
#echo   stream  tcp     nowait  root    internal
#echo   dgram   udp     wait    root    internal
#discard        stream  tcp     nowait  root    internal
#discard        dgram   udp     wait    root    internal
#daytime        stream  tcp     nowait  root    internal
#daytime        dgram   udp     wait    root    internal
#chargen        stream  tcp     nowait  root    internal
#chargen        dgram   udp     wait    root    internal
# These are standard services.
ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  in.ftpd -l -a
telnet  stream  tcp     nowait  root    /usr/sbin/tcpd  in.telnetd
gopher  stream  tcp     nowait  root    /usr/sbin/tcpd  gn

# do not uncomment smtp unless you *really* know what you are doing.
# smtp is handled by the sendmail daemon now, not smtpd.  It does NOT
# run from here, it is started at boot time from /etc/rc.d/rc#.d.
#smtp   stream  tcp     nowait  root    /usr/bin/smtpd  smtpd
#nntp   stream  tcp     nowait  root    /usr/sbin/tcpd  in.nntpd
# Shell, login, exec and talk are BSD protocols.
shell   stream  tcp     nowait  root    /usr/sbin/tcpd  in.rshd
login   stream  tcp     nowait  root    /usr/sbin/tcpd  in.rlogind
#exec   stream  tcp     nowait  root    /usr/sbin/tcpd  in.rexecd
talk    dgram   udp     wait    root    /usr/sbin/tcpd  in.talkd
ntalk   dgram   udp     wait    root    /usr/sbin/tcpd  in.ntalkd
#dtalk  stream  tcp     waut    nobody  /usr/sbin/tcpd  in.dtalkd
# Pop and imap mail services et al
pop-2   stream  tcp     nowait  root    /usr/sbin/tcpd  ipop2d
pop-3   stream  tcp     nowait  root    /usr/sbin/tcpd  ipop3d
imap    stream  tcp     nowait  root    /usr/sbin/tcpd  imapd
# The Internet UUCP service.
#uucp   stream  tcp     nowait  uucp    /usr/sbin/tcpd  /usr/lib/uucp/uucico    -l
# Tftp service is provided primarily for booting.  Most sites
# run this only on machines acting as "boot servers." Do not uncomment
# this unless you *need* it.  
#tftp   dgram   udp     wait    root    /usr/sbin/tcpd  in.tftpd
#bootps dgram   udp     wait    root    /usr/sbin/tcpd  bootpd
# Finger, systat and netstat give out user information which may be
# valuable to potential "system crackers."  Many sites choose to disable 
# some or all of these services to improve security.
# cfinger is for GNU finger, which is currently not in use in RHS Linux
finger  stream  tcp     nowait  root    /usr/sbin/tcpd  in.fingerd
#cfinger stream tcp     nowait  root    /usr/sbin/tcpd  in.cfingerd
#systat stream  tcp     nowait  guest   /usr/sbin/tcpd  /bin/ps -auwwx
#netstat        stream  tcp     nowait  guest   /usr/sbin/tcpd  /bin/netstat    -f inet
# Time service is used for clock syncronization.
time    stream  tcp     nowait  nobody  /usr/sbin/tcpd  in.timed
time    dgram   udp     wait    nobody  /usr/sbin/tcpd  in.timed
# Authentication
auth   stream  tcp     nowait    nobody    /usr/sbin/in.identd in.identd -l -e -o
# End of inetd.conf

FILE: /etc/rc.d/init.d/smb
# chkconfig: 345 91 35
# description: Starts and stops the Samba smbd and nmbd daemons \
#              used to provide SMB network services.

# Source function library.
. /etc/rc.d/init.d/functions

# Source networking configuration.
. /etc/sysconfig/network

# Check that networking is up.
[ ${NETWORKING} = "no" ] && exit 0

# See how we were called.
case "$1" in
	echo -n "Starting SMB services: "
	daemon smbd -D -d3      
	daemon nmbd -D -d3
	touch /var/lock/subsys/smb
	echo -n "Shutting down SMB services: "
	killproc smbd
	killproc nmbd
	rm -f /var/lock/subsys/smb
	echo ""
	status smbd
	status nmbd
	echo -n "Restarting SMB services: "
	echo -n "smbd "
	kill -HUP `pidof -s smbd`
	echo -n "nmbd "
	kill -HUP `pidof -s nmbd`
	echo "done."
	echo "Usage: smb {start|stop|restart|status}"
	exit 1


a) Nothing significant appears in the log files smb.log and nmb.log
b) I dfined my linux box at the LMHOSTS file in the WFW directory and set up TCP/IP
   to read it (Advanced options in TCP/IP configuration).
c) I have printed a Word document to a file in the WFW box, take it to my linux box and
   printed it with the "lpr myfile" without problems, even making "cat myfile > /dev/lp1"

I think this situation may sound stupid to you but I really can't solve it.


THANK YOU FOR YOUR TIME (if you are reading this at this point).

More information about the samba mailing list