UMASK Problems

D. Beier beier at
Mon Sep 29 13:29:28 GMT 1997

I have quite a problem with the new SAMBA version(s) ( both 1.9.17
and 1.9.17 p2). 

When creating a directory in a samba-mounted
unix file system the create mask entry will be ignored. I tried
a lot (changing umasks on the unix boxes (SunOS/Solaris), changing
the create mask entry to a many different values) but nothing
happens at all. Every directory will be created with the permissions
of 755. 

After using the older SAMBA Versions everything worked
fine ( 1.9.16.x ) again. 

Is there an entry I overlooked or what happened here? I'll gratious
for all help.

Regards Daniel Beier

one of the smb.conf's
domain controller =
security = server
password server = pcvw40
guest account = gast
workgroup = LANGROUP
mangled names = Yes
;debug level = 3
;log file = /tmp/smb.log
comment = temporary files 
 path = /tmp
   browseable = yes
   available = yes
   public = yes
   read only = no
   printable = no
   create mask = 0777
comment = Danie's Home
guest ok = no
 path = /export/home/beier
 read only = no
create mode = 775

   Daniel Beier                       Tel.: +49 (0) 391 4090-456
   Fraunhofer Institut IFF            Fax:  +49 (0) 391 4090-491
   Elbstrasse 3-5, D-39104 Magdeburg  Email: beier at

More information about the samba mailing list