Smbclient fails to connect

Steve Barker sbarker at tip.CSIRO.AU
Wed Sep 17 03:21:17 GMT 1997


I've recently upgrade to Samba 1.9.17p1 from 1.9.16p11 (for Solaris 2.5), but 
have now found that smbclient fails to connect to user shares on win95 
machines. I've tried the same login account from a win95 account and am able 
to mount shares from other win 95 machines. I've also tried running the old 
smbclient binary with the new smbd & nmbd daemons, and that lets me log in to 
a 95 machine but gets me no further (ie. 'dir' fails to return a directory 
listing, but returns the block sizes). The error I get from the newly compiled 
smbclient is as follows.

Session setup failed for username=backup myname=TITAN destname=TARA   ERRDOS
- ERRnoaccess (Access denied.)
You might find the -U, -W or -n options useful
Sometimes you have to use `-n USERNAME' (particularly with OS/2)
Some servers also insist on uppercase-only passwords

As far as I can tell there is nothing wrong with the NT account 'backup', and 
everything seems to point to smbclient. I guess I could go back to 1.9.16p11, 
but I'd like to try 17p1 so that I can get subnet browsing working. Any ideas??

 Steve Barker					    Steve.Barker at
 Electromagnetics & Antennas Discipline                Phone: +61 2 9372 4523
 CSIRO Telecommunications & Industrial Physics         Fax:   +61 2 9372 4446 
 PO Box 76, Epping NSW 2121, AUSTRALIA	   	

More information about the samba mailing list