samba on UNIXWARE 2.1.1 (help me please!)

Jeroen joenix at
Fri Sep 5 11:37:26 GMT 1997

Problem with samba-1.9.17 under unixware 2.1.1

I tried to install samba-1.9.17 under unixware 2.1.1 and the following
problem occured:

nmbd seems to work fine, but when I run smbclient -L MY_HOST on MY_HOST
it does start to connect to the right IP and port number, but the
request gets timed out. Like this:

Added interface ip= bcast= nmask=
Opening sockets
Connecting to at port 139
timeout connecting to

I've been running smbd and nmbd as deamons, with this result, so I
killed the
deamons and added the tcp and udp ports to /etc/inetd/services an put
the lines
in inetd.conf, again the nmblookup worked fine, but smbclient timed out.

For the compilation I uncommented the following lines in the Makefile:

LIBSM = -lsocket -lnsl -lc -L/usr/ucblib -lucb -lcrypt -lgen

Compilation generates some warnings:

argument incompatible with prototype: in server.c and util.c
using out of scope dimension: in printing.c and reply.c

These warnings are all in compiling smbd, compiling nmbd doesn't

So I think it's got something to do with it, Do I need some other
options in the
Makefile or do I need to update some lib's or so?

When I use the smbclient on the unix machine to list the available 
resources on a Win95 machine, the request als gets timed out the 
same way.
So there must be more going on, Is there something the kernel needs,
I've never rebuild the kernel on UNIXWARE 2.1.1, I usualy work with
Linux, so if I need to rebuild the kernel, could someone please give me
some hints.

Another thing, when I use netstat -an I can see that port 139 is
listening (tcp), but I dob't see port 137 with netstat, I don't see it
when running samba as deamons nor with the services/inetd method.

So the only thing working now is nmblookup on the UNIXWARE machine,
nothing apears on the win95 boxes.

Thnx for your attention, your kindness, love and a wonderfull next
thousand lifes to all.

Jeroen Vriesman.

More information about the samba mailing list