SAMBA digest 1466

Andrew Patterson andrew at
Wed Oct 22 19:30:32 GMT 1997

> Doug Post at CACI
> 10/21/97 03:19 PM
> I have looked at the previous messages and can still not find the
> answer to
> the problem described below.
> I currently have Samba running on HPUX 10:10 and SunOS 5.3.  I am
> using a
> Windows 95 PC to try to mount a drive to the HPUX machine.  I can
> mount
> drives to the Sun machine using public = no in the smb.conf and
> entering a
> proper userid and password for the Sun machine.
> I can only mount an exported filesystem from the HPUX machine with the
> smbd
> running and properly configured for that machine if I have public =
> yes.
> When I have public = no and use a proper userid and login for the HPUX
> 10.10 operating system, I cannot loggin.  I have used tracing and when
> trying to connect to the file system exported by samba, I can see the
> user_id is correct and the password that is gettting verified is the
> correct length
> Checking password for user dpost (l=9)
> 10/15/97 16:02:16 invalid username/password for test732
>  but the password will not verify.  I have tried making the password
> all
> small letters and all large letters and it still will not verify the
> password.
	[adp]   I have had problems with this before on an HP-UX 10.20
system.  I traced it down to the use of punctuation characters in
passwords.  As far as I could tell, the only valid passwords were 8 or
less characters consisting of characters in the range [a-zA-Z0-9].  

	I also found that I had to send a SIGHUP to the samba server to
get it to recognize changes in a smbpasswd file.

>   Does anyone have any ideas?  -They would be greatly appreciated.
> You can
> also email me at dpost at

   Andrew Patterson                    	      	Voice:  (970) 229-3261
   Hewlett-Packard Company               		FAX:    (970)
   Software Engineering Systems Lab          	email: andrew at
   3404 East Harmony Road / MS 7
   Fort Collins, Colorado  80525   

More information about the samba mailing list