Joshua Heling jrh-sambalist at
Mon Oct 13 03:41:12 GMT 1997

Michael Huttinger writes:
>On Thursday, October 09, 1997 4:31 PM, Simon Hyde [SMTP:shyde at] 
>> On Fri, 10 Oct 1997 02:48:16 +1000, you wrote:
>> >I was wondering if anyone out there has been able to get the command:
>> >
>> >	NET PASSWORD \\sambaserver
>> >
>> >to work from within Windows95 talking to a Samba server?
> [ ... snip ... ]
>Been there, done that about a zillion times, and I never seemed to get the 
>right settings.  For program, we're using the standard Linux passwd, and 
>for chat (hmm, trying to remember as I don't have the box here to look at) 
>something _similiar_ to the default, but not exactly.  I tried to match it 
>up to what the passwd program does for any normal user, but no matter what 
>happens the command always fails.  Perhaps I'll bump up the debug output 
>and see if anything significant is in the log files.
>What I'd like to know is if anyone has gotten this to run on a Linux 
>machine (RedHat 4.1, kernel 2.0.27, and Samba 1.9.17p2)  If so, what 
>configuration did you use?  Is using passwd the problem?

I actually tried it on almost that exact configuration (using 2.0.30 instead) 
two weeks ago.  I also had absolutely no luck ... I don't think it's the 
passwd program, though, because I tried to write a noop shell script that 
would log (using logger(1)) each step of the process -- I never really got 
anything in the logs.

I didn't have time to deal with the issue, so I ended up hacking together a 
perl script that changes both the UNIX password and the smbpasswd file 
simultaneously, and have the users telnet into an account that has said shell 
as its login shell .. kludgy but I had to get something working immediately.

Could someone who is successfully using the 'NET PASSWORD ..' support provide 
any insight about what might be wrong?


Joshua Heling				    jrh at

More information about the samba mailing list