Samba not removing lock files?

Dieter Rothacker Didi at
Tue Dec 9 15:49:08 GMT 1997

charles at wrote:
> Yesterday I posted about a problem where I couldn't delete or rename some
> files.  I now have a little more information.  The problem only occurs after I
> have tried to run an executable or opened a file that is located on a Samba
> share with any application.
> After I have tried to run a program, or load in a file, I can no longer rename
> or delete that file.  This is because even after the application has exited
> or the file has been closed by the application, Samba still has a lock on the
> file:
> 12110  DENY_NONE  RDONLY  pub1/t/test.txt   Mon Dec  8 18:01:52 1997
> 12110  DENY_WRITE RDONLY  pub1/t/test.txt   Mon Dec  8 18:01:52 1997
> Why is this?  The lock file does seem to go away after a period of time.  Why
> doesn't the lock get removed immediately upon close?


this problem vanishes entirely with the new 1.9.18 series that supports
real smb file locking. The fake oplocks from 1.9.17 always behave in the
way you describe.
I am using 1.9.18alpha12, and my Win95 even puts out a correct error
message if I try to delete a file that is in use. As soon as the file
is closed, Win95 permits to delete it.

Apart from that, it works even more stable than 1.9.17p4.

Dieter Rothacker

More information about the samba mailing list