Printing problem with smb pw encryption

Rod Evans rod at
Tue Aug 19 00:54:05 GMT 1997

A week or so ago I upgraded from Samba 1.9.13 to 1.9.17alpha5 and
configured SMB password encryption.
Everything works fine except for printing from all clients (Win3.11,
Win95, WinNT) to a Samba-shared printer.
Prior to the upgrade, printing worked fine, so I'm presuming the problem
is something to do with password encryption (the NT client returns a
"Access Denied" error, Win95 returns one of those "unknown system error"
But the thing that has me puzzled is that printing doesn't need a password
(public = yes) and this worked fine before!
Other non-passworded public shares also work fine.
I've checked that user "nobody" can print, and again, this worked fine
before the upgrade to 1.9.17alpha5.
I've scanned the archives but found nothing apparently related to this

Any clues or suggestions gratefully welcomed.

Here are the relevant sections of my smb.conf -

   security = share
   printing = sysv
   printcap name = /opt/samba-1.9.17alpha5/etc/printcap
   load printers = yes
   guest account = nobody
   password level = 1
   encrypt passwords = yes

   comment = All Printers
   browseable = no
   printable = yes
   path = /tmp
   public = yes
   writable = no
   create mode = 0700

   comment = DSL Foyer Printer
   printer = dsl
   path = /tmp
   browseable = yes
   printable = yes
   public = yes
   writable = no
   create mode = 0700

Thanks in advance for any help,


| Rod Evans     Divisional Manager      CSIRO Division of Animal Production |
|               (Networks/Computing)    Locked Bag 1, Delivery Centre       |
|                                       Blacktown, NSW 2148                 |
| Internet:                             AUSTRALIA                           |
| R.Evans at      Tel: (61) (02) 9840 2700            |
|                                       Fax:           9840 2940            |

More information about the samba mailing list