Incomplete backups with tar option of smbclient.

Roger Stansfield email- R.Stansfield rs at
Wed Aug 13 12:44:22 GMT 1997

We use the tar option of smbclient (Samba 1.9.16p9, SunOS 4.1.3) to
backup Windows 95 PCs:

smbclient "\\${server}\backup" -U COMPUTING -d 1 -D "\" -Tc tarfile >! logfile

backup is set as a share of c:\

The backups are incomplete (as shown by the logfile and gzip -tf tarfile). 
Typically, only very roughly 5700 of 6600 files get copied.

I expect I've got a bad configuration or command line option wrong so
can someone help me? Also, is anyone getting a definitely complete
backup? I'm now going on to over-diagnose the problem!

We think it is complete directories that fail to get backed up. Doing a
backup several times in a row from a single PC leads to different
directories missing. This has happened on at least three different PCs,
all Windows 95 (we do not use this backup for non-Windows 95 machines).
No sign of disk corruption. The tar structure looks fine. In twelve
attempts \windows\Start Menu\Programs has never been backed up though
DOS 8.3 style directories and files are also skipped sometimes. We have
tried full access and read only on the share. In general, *.lnk files
and long file names are handled OK. The Samba diagnostic tests work
and Samba works fine generally.

The interactive tar command of smbclient behaves the same and we have
also tried this with Samba 1.1.15p1 running on Solaris 2.5: still no

> Roger Stansfield,
> Rowett Research Institute, Bucksburn, Aberdeen, AB21 9SB, Scotland, U.K.
> Telephone: 01224 716677. Fax: 01224 716629.
> mailto:R.Stansfield at

More information about the samba mailing list