SAMBA digest 1374

Mark Backes mark at
Sun Aug 3 14:09:36 GMT 1997

I am trying to upgrade my samba to the just released latest alpha, but
am having the following problems.

I installed shadow passwords onto my linux 4.2 box. That went ok.
Then i installed Samba 1.9.17alpha5.
I asked for standard things and just the inclusion of shadow passwords
and quota

                        FLAGSM = -03 -m486 -DLINUX -DSHADOW_PWD -DQUOTAS
                        LIBSM = -lshadow

When compiling I recived this error:

ld: cannot open -lshadow: No such file or directory.
make: *** [smbd] Error 1

I then copied the file /usr/src/shadow-970616/lib/libshadow.a to /lib
directory and recompiled with the same make file.

It compleated Suscessfully ???

But I nw recive the error when trying to log onto the samba server that
The domain password you supplied is not correct, access to your login
server is denied.
I tried different usernames and even root but all gave the same error.
On the server running smbclient -L workgroup just says:
Added interface ip= bcast= nmask=255.255.255.x
and hangs there till I press ctrl-c.

When I Run smbpasswd it replys: smb password encryption not selected in

Is this problem related to the fact that I might have coppied the wrong
file to the /lib directory and if so, what files are suposed to be
If anyone has seen or heard of this problem or might know a way to fix
this, I would greatly appreciate your help.

Thanks Mark.

More information about the samba mailing list