Samba 2.0.6 on Alpha VMS - Passwords

John E. Malmberg malmberg at
Fri Dec 7 05:13:00 GMT 2001

"Fachetti, Robert" <fachetti at> wrote:
> More dumb questions from a new Samba user:
> I successfully (or so I thought) implemented the "security = USER" in the
> SMB.CONF file:
> I logged on as user SYSTEM
> I ran:
> $ sbmpasswd -a myNetworkUsername
> New SMB password:
> Retype new SMB password:
> Added user myNetworkUsername.
> Password changed for user myNetworkUsername.
> That all seemed to work until today. Today my network (Windows NT master
> domain) password was about to expire so I changed it. I then tried to
> re-establish my connection to my Samba share. I was now prompted for a
> password by the "Map Network Drive" function of my "Network Neighborhood"
> icon. This sent up a red flag that I had to change my password on my Samba
> server to match my new Network password. 
> I logged on as user SYSTEM, then did a:
> $ sbmpasswd -h
> smbpasswd [options] [username] [password]
> options:
>   -s                   use stdin for password prompt
>   -D LEVEL             debug level
>   -U USER              remote username


>   -r MACHINE           remote machine
>   -R ORDER             name resolve order
>   -j DOMAIN            join domain name
>   -a                   add user
>   -d                   disable user
>   -e                   enable user
>   -n                   set no password
>   -m                   machine trust account
> So I tried to do a $ smbpasswd "-U" and this is what I got:
> $ smbpasswd "-U" myNetworkUsername
> New SMB password:
> Retype new SMB password:
> Failed to find entry for user myNetworkUsername.
> Failed to change password entry for myNetworkUsername

"-U" is attempting to set the password on a remote NT system.  I think 
that you need a trust set up to do that.  I did not have enough 
resources to test out that option.

If you do not use the "-U", it should just work to update the local

"-U" basically requires "-r".  Since SAMBA 2.0.6 does not know how to 
update it's own smbpasswd file through a network connection, that is why 
it could not find an entry.

The code is all in place the same as the UNIX version, so if the UNIX 
version of SAMBA 2.0.6 can do something, I would expect it to work the 
same way on the OpenVMS version.

wb8tyw at
Personal Opinion Only

More information about the samba-vms mailing list