buggy krb5 ccache behavior and cmocka unit tests

Christian Merten christian at merten.dev
Wed Sep 28 12:04:28 UTC 2022


1.) I encountered a few issues when using other ccache names in 
samba-tool. For example:

samba-tool user list --use-kerberos=required --use-kerberos=required 


although klist correctly shows a ticket that is working with ldapsearch.

Also using --use-krb5-ccache=DIR gives a segmentation fault. The 
segmentation fault is thrown somewhere in the python function 
set_named_ccache patched in auth/credentials/pycredentials.c. I tried to 
track it back to the actual c code, but I stumbled upon cmocka tests. 
This leads me to my second question:

2.) How do I run cmocka unit tests? I tried make subunit-tests 
TESTS=auth.credentials.tests.test_creds but I only get: skipping subunit 
(testscenarios are not available).

Best regards

Christian Merten
PGP Key: https://keys.openpgp.org/vks/v1/by-fingerprint/904AB78A7046431E4B8E96D2D953D69721B948B3

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 840 bytes
Desc: OpenPGP digital signature
URL: <http://lists.samba.org/pipermail/samba-technical/attachments/20220928/2eb47021/OpenPGP_signature.sig>

More information about the samba-technical mailing list