Problems after upgrading file server to 4.12.1

Daniele Dario daniele.dario at
Tue May 12 09:42:59 UTC 2020

Hi Samba team,
some days before release of 4.12.2 I upgraded our file server and our DCs to
4.12.1 from 4.11.6 and everything went fine. These days of lockdown not many of
us are in the company and as far as I could test from my linux box, auth and
network shares were working.

These days we're getting back to work and one of the guys told me that he
couldn't see the files in network shares.

He has a Windows7 box and as soon as he logs in, the shares are mapped and it's
possible to browse them from explorer but in a few, if he tries to browse them
again, he gets the error message "the process cannot access the file because it
is being used by another process".

I tried to unmap all shares, restart and some 10th of seconds after login the
error comes up.

I tried to open a cmd prompt and if I run dir on a share it works. Than also
explorer works but again after some seconds the problem rises again.

Before to revert to previous 4.11.6 that was installed, I'd like to know if this
is a problem related only to this particular box or to Win7 or if you have some
hints to help me solve the issue.

Thanks in advance,

More information about the samba-technical mailing list