no avahi after armhf build on raspbian - no error but advertising disappears

ArtMG smblock at
Thu May 7 20:26:28 UTC 2020

When I install Samba from the Raspbian repos and set up a share, the automatic multicast registration (Bonjour announcement) through Avahi works fine. It also works fine when I install Samba from the dev armhf repos kindly supplied by L.P.H.van Belle. 

However, when I compile the project myself from source, I am not managing to get avahi integration working automatically. There are no compile errors that appear of any significance, just a bunch of deprecation warnings.

My steps were:

* fresh build of (latest)
* sudo apt update | dist-upgrade
* install depends from;a=blob_plain;f=bootstrap/generated-dists/debian10/;hb=v4-12-test
 * as directed in
* sudo apt install avahi-daemon
 * already there

git clone --single-branch --branch=v4-12-stable --depth=1
cd samba
sudo make install

I have tried the following with ./configure \ 


--without-ad-dc --enable-avahi --enable-debug

 --prefix=/usr --exec-prefix=/usr --sysconfdir=/etc \
 --localstatedir=/var --libdir=/usr/lib/$DEB_HOST_MULTIARCH \
 --with-privatedir=/var/lib/samba/private \
 --with-smbpasswd-file=/etc/samba/smbpasswd \
 --enable-fhs --enable-spotlight --with-systemd \

I even tried all the options LPH mentioned in

The configure checking looks ok

Checking for header avahi-common/watch.h : yes
Checking for header avahi-client/client.h : no
Checking for library avahi-client : no
Checking for avahi_client_new : not found
Checking for macro avahi_client_new : not found
Checking for library avahi-common : yes
Checking for avahi_strerror : ok

But whenever I restart my bonjour browser shows no services coming out of avahi. 
For my /var/log/samba/log.smbd (which also tells you my smb.conf) check out
I welcome any suggestions of where else to look for diagnostics or ideas to try during configure/make
Thanks, Art

More information about the samba-technical mailing list