regshell.c: compiler uses -m32 as well as -m64

Rouven WEILER Rouven_Weiler at
Sun Jan 26 06:52:02 UTC 2020

The system is Openindiana which is based on Illumos. Frankly said it is the „gcc“ version of Solaris.
Right now I just wanted to update to distro-package. Therefore, on e just needs to change the Makefile in the respective package build system.
For an impression here a link: <>
Using that build system I actually do not set the -m64 on my own, it it done in the background of the openindiana Makefiles. 
If samba does set that also I cannot tell as I am not very familiar with waf.

Version 4.11.4 of samba worked very well in that build environment, version 4.11.5 throws a "READELF32 error" when linking "regshell.15.o“
regshell has that compiler line I already sent containing a "-m64“ as well as a "-m32“ which does not seem correct and causing the linker error.
So my main idea was to find out why there is this "-m32“ and probably kick it out.

Referring to ncurses: I do not see how this would harm the build. Could you give me some more background.



> Am 25.01.2020 um 21:05 schrieb Andrew Bartlett <abartlet at>:
> On Sat, 2020-01-25 at 18:14 +0100, Rouven WEILER via samba-technical
> wrote:
>> I tried to compile samba-4.11.5 using "-m64“ since it is a 64bit system.
>> The most parts compile and link well.
>> regshell.c does not. In the compiler command I find a "-m64" as well as a "-m32“.
> Can you explain a bit more about the system, and why you need to
> specify -m64 at all?  (I've not heard of this done before).
> As to what is different about regshell, it would be the only ncurses
> program on the system, so this is what might be different. 
> Andrew Bartlett
> -- 
> Andrew Bartlett             
> Authentication Developer, Samba Team
> Samba Developer, Catalyst IT

More information about the samba-technical mailing list