[PATCH] python indent bugfix in dns_hub.py

Jeremy Allison jra at samba.org
Wed Jan 23 16:53:42 UTC 2019

On Wed, Jan 23, 2019 at 11:43:34AM +0200, Isaac Boukris wrote:
> Hi Tim & Jeremy,
> On Tue, Jan 22, 2019 at 11:11 PM Tim Beale <timbeale at catalyst.net.nz> wrote:
> >
> > Hi Isaac,
> >
> > I think what you're seeing is the same essential problem (slowness
> > responding to the DNS query), it's just manifesting in a different way.
> > In your case it looks like it's taking longer than 5 seconds, so the
> > s.recv() times out. In my case, it's taking less than 5 seconds, so the
> > s.recv() is OK, but the sock.sendto() fails (because the client has
> > given up).
> Note that the error I get locally isn't necessarily exactly the same
> as the one I got on GitLab. I only noticed the same final error:
> ERROR: Failed to find a writeable DC for domain 'SAMBA.EXAMPLE.COM':
> The object name is not found.
> See logs from my local machine on current master (which already
> includes the increase of DNS_REQUEST_TIMEOUT) in attached
> current_master.log file.
> > You could try increasing the timeout dns_hub,py uses (e.g. attached).
> I tried it anyway, but it didn't make any difference.
> On Wed, Jan 23, 2019 at 3:07 AM Jeremy Allison <jra at samba.org> wrote:
> >
> > Here is my test python-retry patchset. As per Metze's instructions
> > DO NOT PUSH ! :-).
> >
> > I'm running it in gitlab-ci right now, and wondered if you could
> > see if it fixes Isaac's issues ?
> I still get the same error on my local machine, with this patch
> applied. See log in attached with_jras_patch.log file. Sorry. I'll try
> to take a closer look into my local replica.

Yeah, this is starting to look like something strange in your
local environment.

My latest gitlab-ci test (with my retry patch applied) had
no trouble finding 'a writeable DC for domain 'SAMBA.EXAMPLE.COM''

INFO 2019-01-23 01:45:35,280 pid:29201 bin/python/samba/join.py #103: Finding a writeable DC for domain 'SAMBA2000.EXAMPLE.COM'
dns_hub: sending to address ('', 39203) for name _ldap._tcp.SAMBA2000.EXAMPLE.COM

With the increase of DNS_REQUEST_TIMEOUT the gitlab-ci
builds now seem much more stable (modulo the usual unexplained
flakeyness :-).

More information about the samba-technical mailing list