GitLab merge request 200 DNS related failure

Isaac Boukris iboukris at
Mon Jan 21 21:44:50 UTC 2019

Hi Volker,

I'm having some troubles to pass tests on gitlab, due to some DNS
failure, like this:

As it reproduced for me locally, I tried to chase it with git-bisect
and got a DNS related commit; so although I don't understand what's
going on and although it's the first time I try to use git-bisect, I
thought you might want take a look.

To my understanding it should reproduce on master with:
$ ./configure --enable-debug --enable-selftest  && make && make test
FAIL_IMMEDIATELY=1 TESTS=samba4.drs.repl_schema

Here's how I tried to bisect it:

[admin at f samba]$ git log -1 --oneline
60aa7b3634e (HEAD -> master) group_audit: error handling in group change

[admin at f samba]$ git bisect start HEAD HEAD~90 --
Bisecting: 39 revisions left to test after this (roughly 5 steps)
[33de2f0727e939d404781672633c360b5fa81709] Merge remote-tracking
branch 'origin/v4-10-test' into HEAD

[admin at f samba]$ cat
CFLAGS="-O0 -g" ./configure --enable-debug --enable-selftest &&\
git format-patch --stdout -1 7adb9678b538780fbac98d5985c84b2c39920886
| git apply ;\
make && make test FAIL_IMMEDIATELY=1 TESTS=samba4.drs.repl_schema

[admin at f samba]$ git bisect run ./
4b4ae005b2029d55ad95809a535d13eb5ff51174 is the first bad commit
commit 4b4ae005b2029d55ad95809a535d13eb5ff51174
Author: Volker Lendecke <vl at>
Date:   Wed Jan 3 13:26:54 2018 +0100

    addns: Async ads_dns_lookup_srv

More information about the samba-technical mailing list