nss_wrapper 1.1.4 and Samba

Andreas Schneider asn at samba.org
Wed Oct 31 18:44:06 UTC 2018

On Wednesday, 31 October 2018 16:50:37 CET Jeremy Allison wrote:
> On Wed, Oct 31, 2018 at 10:10:46AM +0100, Andreas Schneider via samba-
technical wrote:
> > I've tried to update nss_wrapper in Samba but it fails.
> > 
> > https://gitlab.com/samba-team/devel/samba/pipelines/34920284
> > 
> > The strange thing is that it works perfectly fine if I run it locally. I
> > will try to reproduce it in the docker image.
> Does it fail on sn-devel ? sn-devel is "truth", the gitlab error reports
> are still more of a matrix-like reality :-).

I guess it was a glibc bug we hit. It runs the same Ubuntu version as sn-
devel. I've tracked it down with a git bisect installing nss_wrapper in the 
docker image.


Andreas Schneider                      asn at samba.org
Samba Team                             www.samba.org
GPG-ID:     8DFF53E18F2ABC8D8F3C92237EE0FC4DCC014E3D

More information about the samba-technical mailing list