[PATCH] A bugfix (IMHO) for namemap_cache

Volker Lendecke Volker.Lendecke at SerNet.DE
Tue Oct 16 10:37:09 UTC 2018

On Tue, Oct 16, 2018 at 11:43:17AM +0200, Volker Lendecke via samba-technical wrote:
> On Tue, Oct 16, 2018 at 10:33:04PM +1300, Andrew Bartlett via samba-technical wrote:
> > I've taken the liberty of putting that in the wiki here:
> > 
> > 
> > https://wiki.samba.org/index.php/Samba_CI_on_gitlab#Debugging_CI_failures
> > 
> > I've also added some of my own clues. Please help expand it further,
> > but I wanted to ensure this is written down for others to find.
> Ok, I failed at the "install docker" stage. I can't make it work from
> behind a proxy. Do I have to install this on a machine without any
> firewall restrictions?

I have to correct myself: Of course I could install the "docker"
binary as such, but when I do the "docker run" stage, it seems that
there is no way to get this to fetch the data it needs via a proxy.
I've tried at least 5 different variants I found via internet search,
but none worked. It always comes up with the error message

docker: Error response from daemon: Get https://registry.gitlab.com/v2/: dial tcp connect: connection refused

It looks as if docker requires direct, unfiltered internet access,
despite a ton of webpages saying something else.


SerNet GmbH, Bahnhofsallee 1b, 37081 Göttingen
phone: +49-551-370000-0, fax: +49-551-370000-9
AG Göttingen, HRB 2816, GF: Dr. Johannes Loxen
http://www.sernet.de, mailto:kontakt at sernet.de

More information about the samba-technical mailing list