[PATCH] A bugfix (IMHO) for namemap_cache

Andreas Schneider asn at samba.org
Tue Oct 16 08:58:45 UTC 2018

On Tuesday, 16 October 2018 10:14:45 CEST Volker Lendecke via samba-technical 
> On Tue, Oct 16, 2018 at 07:38:54AM +0200, Volker Lendecke via samba-
technical wrote:
> > On Mon, Oct 15, 2018 at 11:45:31AM -0700, Jeremy Allison wrote:
> > > make test TESTS=samba4.ldap.password_lockout
> > > 
> > > locally with the patch passes. Is it possible you
> > > just got unlucky twice on autobuild with the same
> > > usual ad-dc python flakyness ?
> > 
> > Possibly. The gitlab pipeline failed three times in a row, but a full
> > autobuild on sn-devel worked. The way I run it is via
> > 
> > nohup /usr/local/bin/autobuild-private.sh > build.log 2>&1 &
> > 
> > in a separate checkout directory on sn-devel and wait for the email.
> gitlab still does not like this. After a successful run on sn-devel I
> gave it another try, but it still fails with
> samba4.ldap_schema.python(ad_dc_ntvfs)(ad_dc_ntvfs)
> which means there is a significant difference between gitlab CI and
> sn-devel.
> How do I get root access to such a gitlab instance to manually run
> that test in that environment? This is needed, because otherwise I
> don't see how I have a chance to even approach this failure.
> Andrew, can you get me root on such a box?

You can get it the following way:

Install docker and run:

docker run -ti registry.gitlab.com/samba-team/samba:latest /bin/bash

Then you need to clone the samba git repository with your changes and run the 

You can find how to run it in the log of the failed pipeline.


Andreas Schneider                      asn at samba.org
Samba Team                             www.samba.org
GPG-ID:     8DFF53E18F2ABC8D8F3C92237EE0FC4DCC014E3D

More information about the samba-technical mailing list