[PATCH] A bugfix (IMHO) for namemap_cache

Volker Lendecke Volker.Lendecke at SerNet.DE
Tue Oct 16 08:14:45 UTC 2018

On Tue, Oct 16, 2018 at 07:38:54AM +0200, Volker Lendecke via samba-technical wrote:
> On Mon, Oct 15, 2018 at 11:45:31AM -0700, Jeremy Allison wrote:
> > make test TESTS=samba4.ldap.password_lockout
> > 
> > locally with the patch passes. Is it possible you
> > just got unlucky twice on autobuild with the same
> > usual ad-dc python flakyness ?
> Possibly. The gitlab pipeline failed three times in a row, but a full
> autobuild on sn-devel worked. The way I run it is via
> nohup /usr/local/bin/autobuild-private.sh > build.log 2>&1 &
> in a separate checkout directory on sn-devel and wait for the email.

gitlab still does not like this. After a successful run on sn-devel I
gave it another try, but it still fails with


which means there is a significant difference between gitlab CI and

How do I get root access to such a gitlab instance to manually run
that test in that environment? This is needed, because otherwise I
don't see how I have a chance to even approach this failure.

Andrew, can you get me root on such a box?

Thanks, Volker

SerNet GmbH, Bahnhofsallee 1b, 37081 Göttingen
phone: +49-551-370000-0, fax: +49-551-370000-9
AG Göttingen, HRB 2816, GF: Dr. Johannes Loxen
http://www.sernet.de, mailto:kontakt at sernet.de

More information about the samba-technical mailing list