[PR PATCH] python: Add argparse samba options

David Mulder dmulder at suse.com
Thu May 10 12:26:11 UTC 2018


Well, I guess I'll sit on this for a while then.

On 05/09/2018 09:03 PM, Andrew Bartlett wrote:
> On Wed, 2018-05-09 at 07:30 -0600, David Mulder via samba-technical
> wrote:
>>> I agree that argparse is very much nicer than optparse, but it was
>>> introduced in Python 2.7 and we have to support 2.6 until the death of
>>> RHEL6 (and SUSE 11?).
>> Ah, I guess I should have checked the age of argparse (did not think of
>> this). Well, this doesn't *replace* getopt.py, just provides a version
>> that uses argparse also. Is anybody backporting new code to older
>> distros that need optparse?
> It isn't about backporting: folks complained quite bitterly when Samba
> 4.8 as an AD DC didn't run on RHEL6.
>
> Andrew Bartlett
>

-- 
David Mulder
SUSE Labs Software Engineer - Samba
dmulder at suse.com
SUSE Linux GmbH, GF: Felix Imend├Ârffer, Jane Smithard, Graham Norton, HRB 21284 (AG N├╝rnberg)




More information about the samba-technical mailing list