[PATCHES] rename samba_gpoupdate to gpupdate

Andrew Bartlett abartlet at samba.org
Thu Jul 12 19:24:32 UTC 2018

On Thu, 2018-07-12 at 08:30 -0600, David Mulder wrote:
> Your import should be:
> from samba.gpclass import gp_ext
> Not:
> from gp_class import gp_ext
> Otherwise, it looks good. I tested this adding some extensions, and
> everything works. I like the cleaner code Douglas. Good work.

Thanks David.  It took Douglas (and then I) quite some time to clean it
up, so please look carefully.  The patches really do need many more

Sadly they did not land for Samba 4.9, but I have them in an autobuild
now, with that additional patch (which Douglas had already reviewed).

For the patches that remain, can you please look over each one and
confirm that each 'does what it says on the tin', as a big reason we
couldn't go further was that the for a number of them, the patches and
commit messages just didn't make any sense together. 


Andrew Bartlett
Andrew Bartlett                       http://samba.org/~abartlet/
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba

More information about the samba-technical mailing list