Noel Power nopower at
Mon Dec 10 08:28:47 UTC 2018

On 10/12/2018 07:19, Noel Power wrote:
> On 10/12/2018 02:23, Andrew Bartlett wrote:
>>>> (but only on sn-devel)
>>> I'm specifically thinking this shows up when multiple build jobs are
>>> run from one invocation, rather than one at a time.
>> Annoyingly, while I've had this fail twice on sn-devel for a 'git
>> autobuild' it didn't fail when I ran manually, even for
>> all tasks.
> two questions
> 1. what command exactly were you using to build samba-libs manually 
> (that worked)

I'm guessing

     python3 ./script/  X Y Z.....

I can reproduce it working doing that

and I can reproduce the error if I just issue the following

     ./script/  X Y Z.....

The problem I think is due to the way is executed and the 
fact by default it runs with python2

I believe the attached patches will fix it, please have a look


> 2. do you have logs for the failing autobuild ?
>> I'm thinking this might be related to the --extra-python stuff. I
>> would like to get rid of that.  I know metze still wanted ldb, tdb and
>> talloc to support that, but if we can show that building those twice
>> (one with each python) would work for packagers, then perhaps that will
>> be OK.
> lets not be hasty, being able to build with --extra-python is very 
> handy for testing (especially when trying to nail something that works 
> with one version and not with the other) Anyway if this is 
> consistently failing then this sounds like a genuine error
>> (Particularly as this would only be interim until we kill python2 in
>> 4.11).
>> Still very frustrating I know, but can you have a go at this?
>> Andrew Bartlett
> Noel

-------------- next part --------------
A non-text attachment was scrubbed...
Name: more-autobuild-fixes.patch
Type: text/x-patch
Size: 8134 bytes
Desc: not available
URL: <>

More information about the samba-technical mailing list