[PATCH] Fix Gluster bug - unable to create file/directory under root of the share due to empty dirpath during get_real_filename()

Michael Adam obnox at samba.org
Wed Aug 22 16:58:29 UTC 2018

On 2018-08-22 at 09:49 -0700, Jeremy Allison wrote:
> On Wed, Aug 22, 2018 at 06:43:11PM +0200, Michael Adam wrote:
> > >
> > > Your gluster-specific fix, whilst not wrong, isn't general enough.
> > 
> > Hm. You say it's a gluster-specific bug to be fixed.
> > And you fixed it in one layer above the call to
> > the gluster specific function. So yours is too
> > general (I'd say). But mine fixed it at the gluster level
> Nope, as you pointed out there may be other
> filesystems that need this issue fixing in
> the same way.

Yeah, I know... ;-)

> > and you say it's not general enough. How can that
> > be? There's exactly one call between the two places.
> Fixing it in vfs_glusterfs isn't where it's already
> done in get_real_filename_full_scan(),

Oh, great, that kindof convinces me, thanks!

> so doing it
> in get_real_filename() which can call get_real_filename_full_scan()
> makes it general for all VFS filesystems that might need it.

okay...  get_real_filename_full_scan() is *only* called in
get_real_filename(), so do you want me to provide a patch
that removes the check from get_real_filename_full_scan()?
Or do we want to leave it there fore safety, should the
function be called from another location in the future?

> Your fix is specific to Gluster, not general enough.

Yeah, I was mainly bitching about the fact that the
commit message just mentiones gluster. :-)

Cheers - Michael
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 163 bytes
Desc: not available
URL: <http://lists.samba.org/pipermail/samba-technical/attachments/20180822/f72b3c04/signature.sig>

More information about the samba-technical mailing list