Recover deleted objects

Andrew Bartlett abartlet at
Mon Aug 20 20:25:45 UTC 2018

On Mon, 2018-08-20 at 11:18 +0200, Stefan Kania via samba-technical
> Hello Rowland,
> Am 17.08.2018 um 14:48 schrieb Rowland Penny via samba-technical:
> > I could then rename the object, but it still didn't show up in 'wbinfo
> > -u' and most of the attributes were missing. When I tried to add them,
> > this was refused, no matter in what order I tried them.
> > 
> I could not even edit the deleted object anymore. I can search for the
> deleted object and the object will be listed but as soon as I try to
> either edit or rename the object I got the LDAP-Error 32.
> So it seems that recovering an object is not working anymore :-(
> To bad, it was the only chance to get back a deleted SID.
> > I gave up at this point.
> Me too
> Stefan

The procedure documented for Windows AD for tombstone renaimation
should work and is tested.

I posted a script here a while back to use that, and it was reposted
recently slightly fixed.  However it still doesn't work, probably just
missing a 'show_deleted:0' control, but as they say untested code is
broken code.


Andrew Bartlett

Andrew Bartlett
Authentication Developer, Samba Team
Samba Development and Support, Catalyst IT

More information about the samba-technical mailing list