NT_STATUS_FILE_IS_A_DIRECTORY in nosymlinks test

Andreas Schneider asn at samba.org
Mon Jul 3 06:20:22 UTC 2017

On Friday, 30 June 2017 07:03:17 CEST Andrew Bartlett via samba-technical 
> G'Day Andreas,

Hi Andrew,
> I've been trying to make our test environments run in parallel, but
> when I enable that on the Catalyst Cloud, using this branch:
> https://git.samba.org/?p=abartlet/samba.git/.git;a=shortlog;h=refs/heads/par
> allel-test
> I (about 50% of the time) get failures in
> test_nosymlinks() in test_smbclient_s3.sh
> UNEXPECTED(failure): samba3.blackbox.smbclient_s3.SMB3.plain
> (ad_member) member creds.follow symlinks = no(ad_member)
> (sorry for the garbled output, something very odd is going on in the
> output stream with the escaping)

I've seen the same and tried to find the issue but couldn't nail it down.

> REASON: Exception: Exception: CLI_FORCE_INTERACTIVE=yes
> /home/ubuntu/autobuild/b20147/samba/bin/smbclient
> -ULOCALADMEMBER/ubuntu%loCalMemberPass //LOCALADMEMBER/nosymlinks -I
> --configfile=/home/ubuntu/autobuild/b20147/samba/bin/ab/client/client.conf
> -mSMB3 NT_STATUS_ACCESS_DENIED opening remote file     est\source
> CLI_FORCE_INTERACTIVE=yes /home/ubuntu/autobuild/b20147/samba/bin/smbclient
> -ULOCALADMEMBER/ubuntu%loCalMemberPass //LOCALADMEMBER/nosymlinks -I
> --configfile=/home/ubuntu/autobuild/b20147/samba/bin/ab/client/client.conf
> /home/ubuntu/autobuild/b20147/samba/bin/smbclient
> -ULOCALADMEMBER/ubuntu%loCalMemberPass //LOCALADMEMBER/nosymlinks -I
> --configfile=/home/ubuntu/autobuild/b20147/samba/bin/ab/client/client.conf
> file       est
ooar       estfile Try "help" do get a list of possible
> commands.
> smb: \> cd test
> smb:    est
ooar\> ls
>   .                                   D        0  Fri Jun 30 03:27:08 2017
>   ..                                  D        0  Fri Jun 30 03:27:08 2017
>   testfile                            D        0  Fri Jun 30 03:27:08 2017
>                 10287416 blocks of size 1024. 3260044 blocks available
> smb:    est
ooar\> get testfile -
> file       est
ooar       estfile smb:    est
ooar\> quit
> failed - NT_STATUS_XXXX doing cd fooar; get testfile on 
> osymlinks
> It would be great to make some progress on this, because in the
> successful runs, I see autobuild times drop by 60mins (288 -> 218 on an
> identical VM)!
> I had assumed this was due to re-use of the dev/inode, but I tried the
> attached and it didn't help.  (This happens when files are created or
> deleted on the client side, not the server side).

I've sent a mail to Jeremy who wrote the code and test for the CVE regression, 
but he asked for a reproducer. I can only reproduce it if I run the test 20 
times in a loop then normally it happens once.

> Another idea would be to wipe the xattr.tdb file between each test.
> My final idea is to have as much of the deltree and mkdir etc be done
> over SMB, so they will get an entry in the xattr.tdb, but I've not had
> time to do this yet.

Hmm. Jeremy any ideas?


P.S. Metze and I started to improve selftest. However I couldn't get the 
following patch working yet:


Some tests are failing but we couldn't nail it down to why and where.

Andreas Schneider                   GPG-ID: CC014E3D
Samba Team                             asn at samba.org

More information about the samba-technical mailing list