[PATCH] samba-tool throws error if there is an empty FSMO role

Andrew Bartlett abartlet at samba.org
Thu May 5 17:22:01 UTC 2016

On Thu, 2016-05-05 at 15:05 +0100, Rowland Penny wrote:
> OK, so I re-read all Andrews posts, decided to try to do what he
> said, 
> set up the testenv and see what happens with the stock fsmo.py.
> He said:
> If you run "SELFTEST_TESTENV=fl2000dc:local make testenv"
> Then you can play in that environment.
> so I tried that and it wouldn't work, but the error message told what
> was wrong, I wasn't in the root dir of the Samba tarball.
> Moved there and tried again:
> SELFTEST_TESTENV=fl2000dc:local make testenv
> and got this:
> Waf: Leaving directory `/usr/src/samba/samba-4.4.3/bin'
> 'build' finished successfully (4m12.098s)
> ERROR: You must use --enable-selftest to enable selftest
> Makefile:27: recipe for target 'testenv' failed
> make: *** [testenv] Error 1
> So from this, I think I will need to do this:
> Download Samba tarball
> Unpack tarball
> cd into directory created
> run './configure --enable-selftest' along with any other configure 
> options I require
> make
> SELFTEST_TESTENV=fl2000dc:local make testenv
> Is this correct ??

Pretty much.  I would check out git master instead, as that is what you
will be patching, and run ./configure.developer rather than ./configure
--enable-selftest (due to other reported bugs I've not yet dug into,
and we don't want to get into here), but otherwise, that is correct.


Andrew Bartlett

Andrew Bartlett                       http://samba.org/~abartlet/
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba

More information about the samba-technical mailing list