static compile samba3 for arm

Gustavo Zacarias gustavo at
Tue Oct 14 17:56:21 MDT 2014

On 10/14/2014 05:13 PM, Jed Evnull wrote:

> I need help doing a static compile of samba3 for arm.  Nothing I've tried
> works, my binaries are always synamically linked.

> Currently I'm building on linux mint i386, but I've used other distros w/o
> success.
>   The toolchain I'm using is from sourcery, but I've tried others w/o
> success.
> I'd appreciate any help.  Thanks!

Without posting what/how it fails i don't think helping will be easy.
I'd say you try with buildroot ( i usually
maintain samba/samba4 packages and just tried samba3 for an emulated arm
target (qemu-arm-versatile) which works just fine.
Just use an internal uclibc toolchain with static=on (latest buildroot
git master i'd suggest since many static build fixes were done lately).
Didn't try with samba4 itself, that'll probably be a challenge and it
will be big, very big.
I can provide you with the qemu disk image and/or a tarball so you can
fetch the binaries if you feel that's faster than building yourself, but
really it's a pretty standard configuration.

More information about the samba-technical mailing list