posix locking on OCFS2

Michael Adam obnox at samba.org
Sun Nov 23 13:43:00 MST 2014

On 2014-11-23 at 21:30 +0100, steve wrote:
> On 23/11/14 21:23, Michael Adam wrote:
> >On 2014-11-23 at 18:23 +0000, Rowland Penny wrote:
> >>All I want to do is get the documentation on the wiki updated correctly, so
> >>that users can follow it and end up with the results they require.
> >
> >Right, but I think David was absolutely right in reverting
> >your note on the wiki, since
> >a) There was afaik no evidence/detail for ctdb not working on ocfs2.
> What more evidence do you need?
> 2014/07/11 08:18:28.865342 [set_recmode:27959]: ctdb_recovery_lock: Got
> recovery lock on '/cluster/ctdb/lockfile'
> 2014/07/11 08:18:28.871862 [set_recmode:27959]: ERROR: recovery lock
> file /cluster/ctdb/lockfile not locked when recovering!

That is no detailed evidence.
We need to see the whole picture.
If we don't know how your file system is configured
it is just a black box and we can't imply anything
from the message above.

The first thing to test is the "ping_pong -rw" test.
If that works and you still get the above error,
I am inclinde to take a deeper look.

Otherwise I'd still say there's probably a misconfiguration in
your file system.

> Chan has just reported the very same error.

Ok, maybe the same maybe not. Not enough detail to really tell.
So there are at least 2 problematic setups. Not a general
statement of ctdb not working on ocfs2...

> >b) The notice from the people that do run samba + ctdb + ocfs2
> >    that it works as expected.
> Where?

E.g. David. I also heard from Jim McD. several years ago
when OCFS2 started to work with ctdb.

> >So, your effort to improve the wiki documentation is
> >highly appreciated, Rowland, but in this case, I am
> >afraid the change was premature.
> We suggested someone added it in an effort to save others the time it takes
> to realise something is wrong. He was right to add it to the wiki.

Well, we can't just say on the wiki or elsewhere  that
"ctdb does not work with ocfs2". This is simply not true.
We can try to debug your setup. And maybe there is indeed
a problem, or a bug. Them we can try to fix it. 

> Thanks,
> José

I am utterly confused. I thought I was talking to someone called
"steve"... :-O

Cheers - Michael

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.samba.org/pipermail/samba-technical/attachments/20141123/485ec276/attachment.pgp>

More information about the samba-technical mailing list